Locale Execute Plug-In

This plug-in is outdated. Please use Secure Settings by intangibleObject instead. It has a lot more features, and it's actively maintained. If you really need the Locale Execute Plug-In for some obscure reason, you can still download it from here.

With this plug-in you can use Locale to execute a Linux command.

You can use these prefix characters:

Comment line.
Use root. Works only if you have root (su) already. If you have the "superuser.apk" it will ask for permission to gain root access for each line that starts with !.
Don't show a Toast. Works only in the first line.
Show only a Toast. Works only in the first line.

For example you can use it to start QuickSSHd with this command:

This works with QuickSSHd 2.0.3 or later, which is in the market now, since 2010-08-13.

It's in a form field here, so you (and I) can easily copy and paste it.

The two icons used in this plug-in were released by Everaldo Coelho and YellowIcon under the LGPL. See here for more info.